Root server

A root server is a special server in the domain name system that tells a computer what name servers to use for a single top level domain like .com or .net.[…

Root server

A root server is a special server in the domain name system that tells a computer what name servers to use for a single top level domain like .com or .net.[1] There are 13 root servers that are in use. They use the letters A through M.[2]

A root server is used when a computer tries to look up a domain. For example, if a person types www.google.com into a web browser, their computer will ask their ISP what the IP address for www.google.com is. If the ISP's DNS server does not know (does not have it cached), it will ask a root server which DNS server can tell it the address. The ISP's root server will then get the address from the DNS server that the root server tells it to.

History

In 1981, the idea of a domain name system was made as part of RFC 799. RFC 819, RFC 882, and RFC 883 said how DNS was supposed to work and made it easier to understand. In 1984, RFC 920 was the first RFC to say what the top level domains would be for the new DNS. In 1985, the first domain name was made and "modern" DNS began.[3]

References

  1. ↑ "Root Server Deployments". APNIC. Retrieved 26 February 2016.
  2. ↑ "Root Servers". IANA. Retrieved 26 February 2016.
  3. ↑ Rader, Ross. "One History of DNS" (PDF). Retrieved 29 February 2016.


Content Disclaimer

Informasi ini disarikan dari Wikipedia dan disajikan kembali untuk tujuan edukasi. Konten tersedia di bawah lisensi CC BY-SA 3.0. Kami tidak bertanggung jawab atas ketidakakuratan data yang bersumber dari kontribusi publik tersebut.

  1. The information displayed on this website is sourced in part or in whole from Wikipedia and has been adapted for the purpose of restating it. We strive to provide accurate and relevant information, however:
  2. There is no guarantee of absolute accuracy. Wikipedia is an open, collaborative project that can be edited by anyone, so information is subject to change.
  3. It is not intended to constitute professional advice. The content displayed is for informational and educational purposes only. For important decisions (e.g., medical, legal, or financial), please consult a professional.
  4. Content copyright. Wikipedia is licensed under the Creative Commons Attribution-ShareAlike License (CC BY-SA). This means that content may be reused with appropriate attribution and shared under a similar license.
  5. Responsible use. Any risk arising from the use of information from this website is entirely the responsibility of the user.