JSON
JSON (JavaScript Object Notation) er et åbent filformat og dataudvekslingsformat, der bruger menneske-læseligt tekst til at gemme og transmittere dataobjekter…
JSON (JavaScript Object Notation) er et åbent filformat og dataudvekslingsformat, der bruger menneske-læseligt tekst til at gemme og transmittere dataobjekter bestående af attribut-værdi-par og tabel (eller andre serialiserbare værdier). JSON er et almindeligt anvendt dataformat med forskellige anvendelser i elektronisk dataudveksling, herunder webapplikationer på servere.[1]
JSON er et programmeringssprogsuafhængigt dataformat. Det blev afledt af JavaScript, men mange moderne programmeringssprog inkluderer kildekode til at generere og parse data i JSON-format. JSON-filnavne bruger filendelsen .json.
Douglas Crockford specificerede oprindeligt JSON-formatet i starten af 2000'erne,[2] og sendte den første JSON-besked i april 2001 med Chip Morningstar.
Standarder
Efter at RFC 4627 havde været tilgængelig som dens "informative" specifikation siden 2006, blev JSON først standardiseret i 2013 som ECMA-404.[3] RFC 8259, udgivet i 2017, er den nuværende version af Internetstandarden STD 90, og den forbliver i overensstemmelse med ECMA-404.[4] Samme år blev JSON også standardiseret som ISO/IEC 21778:2017.[5] Standarderne ECMA og ISO/IEC beskriver kun den tilladte syntaks, hvorimod RFC dækker nogle sikkerheds- og interoperabilitet-overvejelser.[6]
Referencer
- ^ json.org, backup
- ^ Crockford, Douglas (2011-08-28). "The JSON Saga" (video). YUI Library. Hentet 2022-02-21 – via YouTube. Skabelon:Punktliste
- ^ "ECMA-404: The JSON Data Interchange Format" (engelsk) (1st udgave). Ecma International. oktober 2013. Arkiveret (PDF) fra originalen 2013-11-01. Hentet 20. november 2023.
- ^ RFC 8259
- ^ "ISO/IEC 21778:2017 Informationsteknologi — JSON-dataudvekslingssyntaksen". ISO. Hentet 24. juni 2025.
- ^ Bray, Tim. "JSON Redux AKA RFC7159". Ongoing. Hentet 16. marts 2014.
Content Disclaimer
Informasi ini disarikan dari Wikipedia dan disajikan kembali untuk tujuan edukasi. Konten tersedia di bawah lisensi CC BY-SA 3.0. Kami tidak bertanggung jawab atas ketidakakuratan data yang bersumber dari kontribusi publik tersebut.
- The information displayed on this website is sourced in part or in whole from Wikipedia and has been adapted for the purpose of restating it. We strive to provide accurate and relevant information, however:
- There is no guarantee of absolute accuracy. Wikipedia is an open, collaborative project that can be edited by anyone, so information is subject to change.
- It is not intended to constitute professional advice. The content displayed is for informational and educational purposes only. For important decisions (e.g., medical, legal, or financial), please consult a professional.
- Content copyright. Wikipedia is licensed under the Creative Commons Attribution-ShareAlike License (CC BY-SA). This means that content may be reused with appropriate attribution and shared under a similar license.
- Responsible use. Any risk arising from the use of information from this website is entirely the responsibility of the user.